Datacenter Incident
Incident Report for Mercury Cash
Resolved
We have resolved the issue however we are going to plan a window maintenance to work in some additional tasks that will help to avoid this kind of issues happen again.
Posted 4 months ago. Dec 04, 2018 - 21:51 EST
Update
This issue was resolved, thank you for your patience.
Posted 4 months ago. Nov 29, 2018 - 18:21 EST
Monitoring
Our current POP Network and 2 clusters has become inoperative we are currently investigating the issue, our backups has been activated to restore operations.
Posted 4 months ago. Nov 27, 2018 - 18:17 EST
This incident affected: API, Website, ID Verification, Digital Currencies, Customer Support, Cryptocurrency Purchases, Mobile (Android App, iOS Application), Nodes (Bitcoin Network, Ethereum Network, Dash Network), and Payment Methods (WIRE - Bank Transfers).