INCIDENT: Main Server Connectivity Issues
Incident Report for Mercury Cash
Resolved
This issue was resolved, We apologize for any inconvenience this may have caused.
Posted 5 months ago. Nov 20, 2018 - 10:52 EST
Monitoring
We have identified the issue and our services are currently getting back online. We will keep you posted while we monitor the entire infrastructure. Thank you for your patience.
Posted 5 months ago. Nov 19, 2018 - 13:18 EST
Investigating
We have suffered a connectivity issue with one of our main servers, we are currently investigating.
Posted 5 months ago. Nov 19, 2018 - 12:20 EST
This incident affected: Mobile (Android App, iOS Application), API, Website, ID Verification, Digital Currencies, Customer Support, Cryptocurrency Purchases, Nodes (Bitcoin Network, Ethereum Network, Dash Network), and Payment Methods (WIRE - Bank Transfers).