www.mercury.cash - Home Website is not accessible
Incident Report for Mercury Cash
Resolved
This issue has been resolved, thank you for your patience.
Posted 3 months ago. Jun 08, 2019 - 05:08 EDT
Monitoring
Hello all, our engineers have fixed the issue, we are monitoring in order to check if there's another issue in our systems. We apologize for the inconvenience that this might caused you.
Posted 3 months ago. Jun 07, 2019 - 03:47 EDT
Investigating
We have identifies that the Home website is not accessible, our team is checking in order to resolve this issue as soon as possible.
Posted 3 months ago. Jun 07, 2019 - 02:56 EDT
This incident affected: Website.