DDoS Attack - Mitigation Done
Incident Report for Mercury Cash
Resolved
We have mitigated the attack, Thank you for your patience and understanding.
Posted 9 months ago. Oct 15, 2018 - 23:06 EDT
Monitoring
Dear users we have identified a DDoS Attack in one of our servers, we have initiated mitigation process however the website www.miami.exchange and other websites like Press and IR could be unavailable. We apologize for any inconvenience.
Posted 9 months ago. Oct 15, 2018 - 20:29 EDT
This incident affected: Website.