Dash network issue
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 04, 2019 - 09:56 EST
Monitoring
We have successfully completed our update !. We will be monitoring the next 24 hours.
Posted 5 months ago. Feb 27, 2019 - 16:34 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Feb 27, 2019 - 05:14 EST
Monitoring
We have identified an error with the dash network, that is causing some transfers to be delayed. We are working on a solution right now. Thank you for your patience.
Posted 5 months ago. Feb 27, 2019 - 05:01 EST
This incident affected: Nodes (Dash Network).