Transactions degraded performance
Incident Report for Mercury Cash
Resolved
This issue was resolved successfully, we appreciate your collaboration.
Posted 6 months ago. Jan 03, 2019 - 14:25 EST
Investigating
We are currently investigating an issue regarding some BTC transactions not showing in the User statements as expected.
Posted 6 months ago. Dec 18, 2018 - 17:57 EST
This incident affected: Mobile (Android App, iOS Application) and API, Website.