Delayed Transactions
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Jun 08, 2019 - 05:09 EDT
Monitoring
Our engineers have successfully fixed the issue, we are monitoring transactions closely to check that everything is OK.

Thank you for your patience
Posted May 02, 2019 - 12:25 EDT
Identified
We have identified a problem with our Incoming transactions, our engineers are checking and we will provide an update once it's fixed. We apologize for the inconvenience.
Posted May 02, 2019 - 11:10 EDT
This incident affected: Nodes (Bitcoin Network, Dash Network).