Issue Detected on Buy Price on Spanish Devices
Incident Report for Mercury Cash
Investigating
We have identified an issue with Android devices that are showing incorrect pricing when the device is in spanish and has dot (.) as separator of thousand. We currently don't have an ETA to solve this issue, we will keep you posted via our Status Page
Posted Oct 26, 2019 - 05:04 EDT
This incident affects: Mobile (Android App).