General Server Maintenance
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 24, 2018 - 10:31 EDT
Identified
We are experiencing some problems with Crypto transfers and Users Login, we are currently working on the issue.

Keep updated through this channel
Posted 10 months ago. Sep 24, 2018 - 10:20 EDT
Investigating
We are currently performing maintenance in our servers
Posted 10 months ago. Sep 22, 2018 - 22:13 EDT
This incident affected: API, Website and Mobile (Android App, iOS Application).