Datacenter Network Issue
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 18, 2019 - 17:37 EST
Monitoring
We have identified the issue and we are currently monitoring the issue. Thank you for your understanding.
Posted about 1 month ago. Feb 18, 2019 - 15:17 EST
Investigating
Hello, we are currently investigating an issue that is affecting our servers. All services are down.
Posted about 1 month ago. Feb 18, 2019 - 14:37 EST
This incident affected: API, Website and Mobile (Android App, iOS Application).