Mobile App - Issues adding bank accounts
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 05, 2019 - 13:23 EDT
Monitoring
We have released a new version with a fix, after several tests we have not detected any issues. If you detect any issues please contact support@mercury.cash
Posted 3 months ago. Mar 30, 2019 - 23:29 EDT
Identified
We have identified the issue, we are already working on a fix to upload a new version. Thank you for your patience.
Posted 3 months ago. Mar 30, 2019 - 21:11 EDT
Investigating
An issue has been detected using the app to add bank accounts, our engineers are working to identify the issue, in addition, some scroll issues are also happening on iPhone X and XS versions. We will work accordingly to fix these issues and let you know, thank you for your patience.
Posted 3 months ago. Mar 30, 2019 - 14:17 EDT
This incident affected: Mobile (iOS Application).