Dash Delayed Transactions
Incident Report for Mercury Cash
Resolved
This issue was resolved by our incredible engineering team. Thank you for your patience.
Posted 6 months ago. Jan 03, 2019 - 14:24 EST
Identified
We have identified the issue, our engineers are working to apply a fix in order to restore the functionality of the network.
Posted 6 months ago. Jan 03, 2019 - 12:40 EST
Investigating
We have identified a delay in our Dash transactions, our engineers are checking the network nodes in order to identify the issue.
Posted 6 months ago. Jan 03, 2019 - 12:15 EST
This incident affected: Nodes (Dash Network).