USD Deposits/Withdraws Not Available until Further Notice
Incident Report for Mercury Cash
Resolved
We have completed initial integration with our banking partner. Thank you for your patience.
Posted Jul 19, 2020 - 10:37 EDT
Monitoring
For the moment we will be disabling the USD deposits and withdraws until further notice if you need to make a deposit or withdraw of funds we recommend to use any of the available cryptocurrencies or Euro.
Posted Jun 30, 2020 - 17:22 EDT
This incident affected: Payment Methods (WIRE - Bank Transfers).