ETH Delayed Transactions
Incident Report for Mercury Cash
Resolved
This incident has been resolved, thank you for your patience.
Posted 6 months ago. Dec 25, 2018 - 22:47 EST
Investigating
Hello dear users, we have detected a delay on the ETH Transactions, our technicians are working in order to solve it as soon as possible. Thank you for your understanding.
Posted 6 months ago. Dec 24, 2018 - 08:16 EST
This incident affected: Nodes (Ethereum Network).