API & Web Servers Issues
Incident Report for Mercury Cash
Resolved
All the issues has been resolved.
Posted 4 months ago. Oct 28, 2018 - 11:21 EDT
Identified
We have identified some issues in one of our servers, our engineers have been working since early today to remediate the situation. We apologize for any inconvenience. Stay tuned for updates.
Posted 4 months ago. Oct 23, 2018 - 07:51 EDT
This incident affected: Mobile (Android App, iOS Application) and API, Website, Digital Currencies, Cryptocurrency Purchases.