Ethereum Transactions Delayed
Incident Report for Mercury Cash
Resolved
The issue was resolved, thank you for your patience.
Posted Nov 02, 2019 - 06:41 EDT
Monitoring
We have solved the delay in our transactions we still monitoring the network behavior for another 48 hours until close this ticket. Thank you
Posted Oct 31, 2019 - 07:00 EDT
Identified
We have identified an issue with our nodes, Ethereum network appears to be syncing slower than expected, we are working to fix this issue, at the moment transactions can take longer than usual.
Posted Oct 29, 2019 - 18:13 EDT
This incident affected: Nodes (Ethereum Network).