Mercury Cash - Upgrade Verification
Incident Report for Mercury Cash
Resolved
We have successfully finished the maintenance and verification of all upgrades. Thank you for your patience.
Posted 3 months ago. Jan 29, 2019 - 04:45 EST
Identified
We still working on the process of verifying the upgraded features at Mercury Cash, We will update to the resolved status once we complete the verification procedures. Thank you for your understanding.
Posted 3 months ago. Jan 29, 2019 - 04:04 EST
This incident affected: Mobile (Android App, iOS Application), API, Website, ID Verification, Digital Currencies, Customer Support, Cryptocurrency Purchases, Nodes (Bitcoin Network, Ethereum Network, Dash Network), and Payment Methods (WIRE - Bank Transfers).