General platform maintenance
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 15, 2019 - 14:37 EST
Investigating
We are experiencing some connectivity issues, we are investigating this issue
Posted 6 months ago. Feb 11, 2019 - 15:52 EST
This incident affected: Mobile (Android App, iOS Application) and API, Website.