Safari 12 - Webcam issues on MacOS
Incident Report for Mercury Cash
Resolved
This issue was resolved.
Posted 23 days ago. Jan 29, 2019 - 05:01 EST
Investigating
Dear users, after our upgrade we have identified an error using the camera on MacOS + Safari version 12, our team will work this week to get a solution on this matter, in the meantime, we invite you to get the latest version of Google Chrome for MacOS or if you desire to open an account as an individual, please use your mobile device.

Thank you for your patience and understanding.
Posted 23 days ago. Jan 29, 2019 - 04:48 EST
This incident affected: ID Verification.