iOS App - BTC Balance issues
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 18, 2019 - 10:32 EDT
Identified
The issue has been identified and we are working in a fix for our next release for Mobile Apps
Posted 3 months ago. Apr 05, 2019 - 13:21 EDT
Investigating
We have detected that some users and devices are experiencing a crash of our app when they enter in their BTC balance account. Our engineers are investigating this issue.
Posted 3 months ago. Apr 05, 2019 - 08:37 EDT
This incident affected: Mobile (iOS Application).