Credit Card Purchases
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 6 months ago. Aug 22, 2018 - 09:24 EDT
Update
We are continuing to investigate this issue.
Posted 7 months ago. Jul 28, 2018 - 17:17 EDT
Investigating
All our credit card transactions and wire transfer operations for deposits are temporarily disabled. Thank you for understanding
Posted 7 months ago. Jul 22, 2018 - 18:52 EDT
This incident affected: Payment Methods (WIRE - Bank Transfers).