BTC Transactions Delayed
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 21, 2018 - 22:08 EST
Monitoring
Hello, we have detected a delay in our BTC transactions, our team has already identified the issue and we are currently monitoring the fix we implemented.
Thank you for your understanding.
Posted 4 months ago. Dec 21, 2018 - 16:18 EST